Qt는 최신 버전을 쓰세요. > 자유게시판

본문 바로가기

사이트 내 전체검색

자유게시판

Qt는 최신 버전을 쓰세요.

작성일 16-04-28 14:53

페이지 정보

작성자 no_profile devilqoo 쪽지보내기 메일보내기 자기소개 아이디로 검색 전체게시물 조회 4,658회 댓글 2건

본문

Qt 4.x 로 유지보수 하고 있는 데 Windows 10에서 골치 아픈 문제들이 좀 있네요.

한글 입력 도중에 QTextCursor 조작하다가 assertion에 걸려서 죽기도 하고

screen geometry가 제대로 읽혀지지 않는 문제도 있고

기능 추가의 장점도 있지만 최신 OS 지원하려면 기존 레거시 코드로는 한계가 있네요.

암튼 위와 같은 문제로 조만간 Qt 를 과감하게 갈아 엎는 작업을 진행하게 될 것 같습니다.

근데 Qt 4에서 5로 넘어올 때 초기 버전에서 버그가 너무 많아 개발자들의 원성이 자자 했다는 풍문이...

Qt !!!

댓글목록

구름님님의 댓글

profile_image no_profile 구름님 쪽지보내기 메일보내기 자기소개 아이디로 검색 전체게시물
작성일

하지만 사람이 만든 것인데요, 버그는 어쩔 수가..
5.4, 5.5에서 이상이 없다가 5.6에서 이상이 있는 것도 발견 했습니다만;;
델파이 사용할 때 이런면에서 트래이닝을 참 잘했었다능
어쩌면 엠머시기들의 농간일거라는 피해망상인지 사실인지.. 아직도 그러거든요.

freecatz님의 댓글

profile_image no_profile freecatz 쪽지보내기 메일보내기 자기소개 아이디로 검색 전체게시물
작성일

다른 언어들도 윈두우 10 넘어가면서 여러모로 문제가 생긴다고 하더라고요.

제 친구는 c# 으로 개발 중인데, 사용자 권한 체계 때문에 좀 힘든 부분이 생겼다고...

전체 366건 1 페이지
게시물 검색
Copyright © 소유하신 도메인. All rights reserved.
PC 버전으로 보기