SDL 라이브버리 not find? 도와주세여~ > SDL 질문/답변

본문 바로가기
사이트 내 전체검색

SDL 질문/답변

SDL 라이브버리 not find? 도와주세여~

페이지 정보

작성자 혀기 댓글 1건 조회 17,386회 작성일 07-07-09 14:35

본문

linphone-1.5.0을 arm용으로 컴파일 하는 중에 SDL을 ARM용으로 깔아야 한다기에 SDL-1.2.9를 다운받아서 arm용으로 컴파일 하는데 까지 성공했습니다. 그런데 linphone에서 configure 하는 도중에 아래와 같은 erro가 생성 됩니다. 라이브러리를 오만대 다 깔아 보아도 똑같은 현상인데여 라이브러리를 못찾는 걸까여~ 아님... 따른 문제가 있는 걸까여? 답답해 죽겟네염..ㅠ.ㅠ SDL컴파일은 여기에있는 고도리님 문서를 약간 변형해서 따라했습니다. SDL컴파일 옵션은 ./configure --build=i386 --host=armv4l-linux --prefix=/armbuild --enable-shared --disable-static --disable-input-events --enable-video-fbcon --disable-video-qtopia --disable-video-phyton --disable-video-direct --disable-video-ggi --disable-video-svga --disable-video-aalib --disable-video-dummy --disable-video-dga --disable-arts --disable-esd --disable-alsa --disable-video-x11 --disable-nasm --disable-debug --disable-joystick-amigaos --disable-joystick-beos --disable-joystick-bsd --disable-joystick --disable-joystick-dc --disable-joystick-linux --disable-joystick-macos --disable-joystick-mint --disable-joystick-win32 이걸로 주었구요 linphone에서 에러 현상은 아래와 같습니다. .... .... checking for sys/audio.h... no checking alsa/asoundlib.h usability... no checking alsa/asoundlib.h presence... no checking for alsa/asoundlib.h... no checking kde/artsc/artsc.h usability... no checking kde/artsc/artsc.h presence... no checking for kde/artsc/artsc.h... no checking pkg-config is at least version 0.9.0... yes checking for JACK... Package jack was not found in the pkg-config search path. Perhaps you should add the directory containing `jack.pc' to the PKG_CONFIG_PATH environment variable No package 'jack' found no No jack support. checking for SPEEX... yes checking for SPEEX... yes building from linphone source tree, using ../gsmlib/gsm.h checking for FFMPEG... yes checking for avcodec_register_all in -lavcodec... yes checking SDL/SDL.h usability... yes checking SDL/SDL.h presence... yes checking for SDL/SDL.h... yes checking for SDL_Init in -lSDL... no configure: error: Could not find libsdl headers and library. This is mandatory for video support configure: error: ./configure failed for mediastreamer2 도움 부탁드립니다...ㅠ.ㅠ

댓글목록

korone님의 댓글

korone 작성일

checking for SDL_Init in -lSDL... no
configure: error: Could not find libsdl headers and library. This is mandatory for video support
configure: error: ./configure failed for mediastreamer2

여기를 보면 libSDL 라이브러리 내에 있는 SDL_Init함수를 못 찾아서 그렇습니다.
크로스 툴 체인 라이브러리 디렉토리내에 libSDL.so.2.3.9 파일이 존재하지 않아서 그렇습니다.
복사하시고 다시 빌드해주시면 됩니다.

  • 게시물이 없습니다.

회원로그인

설문조사

새로운 홈페이지에 대한 평가

접속자집계

오늘
215
어제
539
최대
3,878
전체
4,094,936

Copyright © korone.net. All rights reserved.